sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / www-apache / mod_vhost_ldap / mod_vhost_ldap-2.4.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit apache-module
7
8 DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
9 HOMEPAGE="https://github.com/oerdnj/mod-vhost-ldap"
10 SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 APACHE2_MOD_CONF="99_${PN}"
18 APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
19
20 DOCFILES="AUTHORS ChangeLog README"
21
22 # We need apr-util[ldap] and apache to build, but the ldap module for
23 # apache is only needed when we try to run the thing.
24 DEPEND="dev-libs/apr-util[ldap]"
25 RDEPEND="=www-servers/apache-2.4*[ldap]"
26
27 need_apache2_4
28
29 src_prepare() {
30         default
31
32         sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c" || \
33                 die "failed to sed version string"
34 }
35
36 src_install() {
37         apache-module_src_install
38         insinto /etc/openldap/schema
39         doins mod_vhost_ldap.schema
40 }
41
42 pkg_postinst() {
43         apache-module_pkg_postinst
44         einfo
45         einfo "Your LDAP server needs to include mod_vhost_ldap.schema and should"
46         einfo "also maintain indices on apacheServerName and apacheServerAlias."
47         einfo
48 }