Set appropriate maintainer types in metadata.xml (GLEP 67)
[gentoo.git] / www-apache / mod_jk / mod_jk-1.2.37.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit apache-module java-pkg-2
8
9 MY_P="tomcat-connectors-${PV}-src"
10
11 KEYWORDS="amd64 x86"
12
13 DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol"
14 HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
15 SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/${MY_P}.tar.gz"
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 IUSE=""
19
20 S="${WORKDIR}/${MY_P}/native"
21
22 APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
23 APACHE2_MOD_CONF="88_${PN}"
24 APACHE2_MOD_DEFINE="JK"
25
26 DOCFILES="CHANGES"
27 CONF_DIR="${WORKDIR}/${MY_P}/conf"
28
29 DEPEND=">=virtual/jdk-1.4"
30 RDEPEND=""
31
32 need_apache
33
34 pkg_setup() {
35         java-pkg-2_pkg_setup
36 }
37
38 src_configure() {
39         econf \
40                 --with-apxs=${APXS} \
41                 --with-apr-config=/usr/bin/apr-config \
42                 || die "econf failed"
43 }
44
45 src_compile() {
46         emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
47 }
48
49 src_install() {
50         # install the workers.properties file
51         insinto "${APACHE_CONFDIR}"
52         newins "${CONF_DIR}/workers.properties.minimal" \
53                 jk-workers-minimal.properties || die
54         newins "${CONF_DIR}/workers.properties" \
55                 jk-workers.properties || die
56         doins "${CONF_DIR}/uriworkermap.properties" || die
57
58         # call the nifty default src_install :-)
59         apache-module_src_install
60 }
61
62 pkg_postinst() {
63         elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
64         elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
65         elog "your own."
66
67         elog "Advanced Directives and Options can be found at: "
68         elog "http://tomcat.apache.org/connectors-doc/reference/workers.html"
69
70         elog ""
71         elog "JNI Worker Deprecation:"
72         elog "Workers of type jni are broken since a long time."
73         elog "Since there is no more use for them, they have been deprecated now,"
74         elog "and will be removed in a future release."
75 }