www-apache/mod_h2: 1.15.8 version bump
[gentoo.git] / www-apache / mod_h2 / mod_h2-1.15.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit apache-module autotools
7
8 MY_P="${PN/h2/http2}-${PV}"
9
10 if [[ ${PV} == 9999 ]] ; then
11         EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
12         inherit git-r3
13 else
14         S="${WORKDIR}/${MY_P}"
15         SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
16         KEYWORDS="~amd64 ~x86"
17 fi
18
19 DESCRIPTION="HTTP/2 module for Apache"
20 HOMEPAGE="https://github.com/icing/mod_h2"
21
22 LICENSE="Apache-2.0"
23 SLOT="0"
24 IUSE="ssl"
25
26 RDEPEND=">=net-libs/nghttp2-1.0
27         >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
28 DEPEND="${RDEPEND}"
29
30 need_apache2_4
31
32 src_prepare() {
33         default
34         eautoreconf
35 }
36
37 src_compile() {
38         default
39 }
40
41 src_install() {
42         default
43
44         APACHE2_MOD_DEFINE="HTTP2"
45         insinto "${APACHE_MODULES_CONFDIR}"
46         newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
47 }