www-apache/mod_dnssd: arm64 keyworded
[gentoo.git] / www-apache / mod_depends / mod_depends-0.7.0_p200702041.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils apache-module
7
8 DESCRIPTION="An apache helper module for handling dependencies properly"
9 SRC_URI="http://upstream.rm-rf.in/${PN}/${P}.tar.bz2"
10 HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_depends/"
11
12 SLOT="0"
13 LICENSE="Apache-2.0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 APACHE2_MOD_CONF="0.7/09_${PN}"
18 APACHE2_MOD_DEFINE="DEPENDS"
19
20 need_apache2
21
22 src_compile() {
23         econf --with-apxs="${APXS}" || die "configure failed"
24         emake || die "make failed"
25 }
26
27 src_install() {
28         AP_INCLUDEDIR=$(${APXS} -q INCLUDEDIR)
29
30         insinto ${AP_INCLUDEDIR}
31         doins include/mod_depends.h || die
32
33         mv -v src/.libs/{lib,}mod_depends.so
34
35         apache-module_src_install
36 }
37
38 # vim:ts=4