dev-util/clair: 2.1.3 bump
[gentoo.git] / www-apache / mod_caucho / mod_caucho-4.0.47.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils apache-module
7
8 DESCRIPTION="mod_caucho connects Resin and Apache2"
9 HOMEPAGE="http://www.caucho.com/"
10 SRC_URI="http://www.caucho.com/download/resin-${PV}-src.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc64 ~x86"
14
15 need_apache2_4
16
17 APACHE2_MOD_CONF="88_${PN}"
18 APACHE2_MOD_DEFINE="CAUCHO"
19
20 S="${WORKDIR}/resin-${PV}"
21
22 # Although building this manually with apxs is bad, trying to make the
23 # build scripts behave is worse. You have to:
24 #
25 # * Patch configure.ac and Makefile.in to respect flags.
26 # * Run eautoreconf (or patch configure and chmod it too).
27 # * Inherit java-pkg-2, DEPEND on virtual/jdk, and define pkg_setup just
28 #   to needlessly satisfy configure or patch out large chunks of it.
29 # * Define src_compile to only build the Apache module.
30 # * It will still report an implicit declaration of cse_free. If you try
31 #   to fix this, it will complain that the argument count doesn't match.
32
33 APXS2_S="${S}/modules/c/src/apache2"
34 APXS2_ARGS="-c -DAPACHE_24 -I../common ${PN}.c ../common/stream.c ../common/config.c ../common/memory.c"
35
36 src_configure() {
37         :
38 }