dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / www-apache / mod_auth_tkt / mod_auth_tkt-2.1.0-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit apache-module eutils
6
7 DESCRIPTION="Apache module for cookie based authentication"
8 HOMEPAGE="http://www.openfusion.com.au/labs/mod_auth_tkt/"
9 SRC_URI="http://www.openfusion.com.au/labs/dist/${PN}/${P}.tar.gz"
10
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-lang/perl"
17 RDEPEND=""
18
19 APACHE2_MOD_CONF="10_${PN}"
20 APACHE2_MOD_DEFINE="AUTH_TKT"
21
22 DOCFILES="README"
23
24 # test suite is completely broken
25 RESTRICT="test"
26
27 need_apache2
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${P}-apache-2.4.patch
31 }
32
33 src_configure() {
34         ./configure --apachever=2.2 --apxs=${APXS}
35 }
36
37 src_compile() {
38         emake
39 }
40
41 src_install() {
42         apache-module_src_install
43         pod2man --section=5 --release=${PV} doc/${PN}.{pod,5}
44         doman doc/${PN}.5
45 }
46
47 pkg_postinst() {
48         apache-module_pkg_postinst
49         einfo "See 'man mod_auth_tkt' for details on the individual directives."
50         einfo "Remember to change shared secret 'TKTAuthSecret' before using!"
51         einfo
52 }