a81501c58bc472071ab592b19075d3b6305cdb7f
[wtk-overlay.git] / webtest-1.2.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7 SUPPORT_PYTHON_ABIS="1"
8 # xml.etree.ElementTree module required.
9 RESTRICT_PYTHON_ABIS="2.4 3.*"
10 DISTUTILS_SRC_TEST="nosetests"
11
12 inherit distutils
13
14 MY_PN="WebTest"
15 MY_P="${MY_PN}-${PV}"
16
17 DESCRIPTION="Helper to test WSGI applications"
18 HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
19 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="amd64 ~arm ppc x86"
24 IUSE=""
25
26 RDEPEND=">=dev-python/webob-0.9.2"
27 DEPEND="${RDEPEND}
28         dev-python/setuptools"
29
30 S="${WORKDIR}/${MY_P}"