virtual/python-futures: [QA] Add missing python metadata variables
[gentoo.git] / virtual / python-futures / python-futures-0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
7
8 inherit python-r1
9
10 DESCRIPTION="A virtual for the Python concurrent.futures module"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
13 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
14
15 RDEPEND="${PYTHON_DEPS}
16         $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' python2_7 pypy)"