papp-text/dos2unix: Bump to version 7.4.1
[gentoo.git] / virtual / mpi / mpi-2.0-r5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit multilib-build
7
8 DESCRIPTION="Virtual for Message Passing Interface (MPI) v2.0 implementation"
9 SLOT="0"
10 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
11 IUSE="cxx fortran romio threads"
12
13 RDEPEND="|| (
14         >=sys-cluster/openmpi-1.10.2-r1[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads(+)?]
15         >=sys-cluster/mpich-3.2-r1[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads?]
16         sys-cluster/mpich2[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads?]
17         sys-cluster/mvapich2[${MULTILIB_USEDEP},cxx(-)?,fortran?,romio?,threads?]
18         sys-cluster/nullmpi[${MULTILIB_USEDEP},cxx(-)?,fortran(-)?,romio(-)?,threads(-)?]
19         sys-cluster/native-mpi
20 )"