virtual/cblas: ppc64 stable wrt bug #700196
[gentoo.git] / virtual / imagemagick-tools / imagemagick-tools-0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Virtual for imagemagick command line tools"
7 SLOT="0"
8 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
9 IUSE="jpeg perl png svg tiff"
10
11 # This virtual is to be used **ONLY** for depending on the runtime
12 # tools of imagemagick/graphicsmagick. It should and cannot be used
13 # for linking against, as subslots are not transitively passed on.
14 # For linking, you will need to depend on the respective libraries
15 # in all consuming ebuilds and use appropriate sub-slot operators.
16 # See also: https://bugs.gentoo.org/show_bug.cgi?id=314431
17 RDEPEND="
18         || (
19                 media-gfx/imagemagick[jpeg?,perl?,png?,svg?,tiff?]
20                 media-gfx/graphicsmagick[imagemagick,jpeg?,perl?,png?,svg?,tiff?]
21         )"