2a1f4271ae8ace678793782ceeda980706718f1c
[gentoo.git] / vdr-devstatus-0.4.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit vdr-plugin-2
7
8 DESCRIPTION="VDR plugin: display the usa status of the available DVB devices"
9 HOMEPAGE="http://www.u32.de/vdr.html"
10 SRC_URI="http://www.u32.de/download/${P}.tgz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="~x86 ~amd64"
15 IUSE=""
16
17 DEPEND=">=media-video/vdr-1.6.0"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         # remove untranslated .po files
22         rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,sl_SI,sv_SE,tr_TR}.po
23
24         vdr-plugin-2_src_prepare
25
26         if has_version ">=media-video/vdr-1.7.28"; then
27                 sed -i "s:SetRecording(\([^,]*\),[^)]*)):SetRecording(\1\):" devstatus.c
28         fi
29 }