subversion.eclass: Use valid domains for examples.
[gentoo.git] / sys-process / psmisc / psmisc-23.2-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A set of tools that use the proc filesystem"
7 HOMEPAGE="http://psmisc.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
13 IUSE="ipv6 nls selinux X"
14
15 RDEPEND=">=sys-libs/ncurses-5.7-r7:0=
16         nls? ( virtual/libintl )
17         selinux? ( sys-libs/libselinux )"
18 DEPEND="${RDEPEND}
19         >=sys-devel/libtool-2.2.6b
20         nls? ( sys-devel/gettext )"
21
22 DOCS=( AUTHORS ChangeLog NEWS README )
23
24 PATCHES=(
25         "${FILESDIR}/${P}-old_comm_len.patch"
26         "${FILESDIR}/${P}-killall_check_truncated_16_char.patch"
27 )
28
29 src_configure() {
30         local myeconfargs=(
31                 --disable-harden-flags
32                 $(use_enable ipv6)
33                 $(use_enable nls)
34                 $(use_enable selinux)
35         )
36         econf "${myeconfargs[@]}"
37 }
38
39 src_install() {
40         default
41
42         use X || rm -f "${ED%/}"/usr/bin/pstree.x11
43
44         [[ -s ${ED%/}/usr/bin/peekfd ]] || rm -f "${ED%/}"/usr/bin/peekfd
45         [[ -e ${ED%/}/usr/bin/peekfd ]] || rm -f "${ED%/}"/usr/share/man/man1/peekfd.1
46
47         # fuser is needed by init.d scripts; use * wildcard for #458250
48         dodir /bin
49         mv "${ED%/}"/usr/bin/*fuser "${ED%/}"/bin || die
50 }