48666031963733dd3ce462b9bbeb6eff8f26acd8
[gentoo.git] / sys-process / parallel / parallel-20200122.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
7 HOMEPAGE="https://www.gnu.org/software/parallel/"
8 SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-3+"
11 SLOT="0"
12 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
13 IUSE=""
14
15 RDEPEND="dev-lang/perl:=
16         dev-perl/Devel-Size
17         virtual/perl-Data-Dumper
18         virtual/perl-File-Temp
19         virtual/perl-IO"
20 DEPEND="${RDEPEND}"
21
22 DOCS="NEWS README"
23
24 src_configure() {
25         econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
26 }
27
28 src_install() {
29         default
30
31         # See src/Makefile.am for this one:
32         rm -f "${ED}"/usr/bin/sem || die
33         dosym ${PN} /usr/bin/sem
34 }
35
36 pkg_postinst() {
37         elog "To distribute jobs to remote machines you'll need these dependencies"
38         elog " net-misc/openssh"
39         elog " net-misc/rsync"
40 }