dev-lisp/sbcl: Updating ebuilds to EAPI 6
[gentoo.git] / sys-process / parallel / parallel-20150622.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
8 HOMEPAGE="https://www.gnu.org/software/parallel/"
9 SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
14 IUSE=""
15
16 RDEPEND="dev-lang/perl
17         dev-perl/Devel-Size
18         virtual/perl-Data-Dumper
19         virtual/perl-File-Temp
20         virtual/perl-IO"
21 # moreutils for `parallel` and grass for 'sql.1' manpage
22 DEPEND="${RDEPEND}
23         !<sys-apps/moreutils-0.45-r1
24         !<sci-geosciences/grass-6.4.1-r1"
25
26 DOCS="NEWS README"
27
28 src_configure() {
29         econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
30 }
31
32 src_install() {
33         default
34
35         # See src/Makefile.am for this one:
36         rm -f "${ED}"usr/bin/sem
37         dosym ${PN} /usr/bin/sem
38 }
39
40 pkg_postinst() {
41         elog "To distribute jobs to remote machines you'll need these dependencies"
42         elog " net-misc/openssh"
43         elog " net-misc/rsync"
44 }