sys-process/procps: Revbump for toprc backwards compatibility
[gentoo.git] / sys-process / evisum / evisum-0.2.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="System and process monitor written with EFL"
9 HOMEPAGE="https://www.enlightenment.org/"
10 SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
11
12 LICENSE="ISC"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15
16 DEPEND="dev-libs/efl"
17 RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
18
19 PATCHES=( "${FILESDIR}/${PN}-0.2.2-respect-cflags-ldflags.patch" )
20
21 src_install() {
22         emake PREFIX="${D}"/usr install
23         einstalldocs
24 }
25
26 pkg_postinst() {
27         xdg_icon_cache_update
28 }
29
30 pkg_postrm() {
31         xdg_icon_cache_update
32 }