www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / sys-power / powerstat / powerstat-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 EGIT_REPO_URI="https://github.com/ColinIanKing/${PN}.git"
7
8 inherit git-r3 toolchain-funcs
9
10 DESCRIPTION="Laptop power measuring tool"
11 HOMEPAGE="https://launchpad.net/ubuntu/+source/powerstat https://github.com/ColinIanKing/powerstat"
12 SRC_URI=""
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 src_prepare() {
20         default
21
22         # Don't compress manpages
23         sed -i  -e '/install:/s/ powerstat.8.gz//' \
24                 -e '/cp powerstat.8/s/.gz//' \
25                 Makefile || die "sed failed"
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)"
30 }