sys-power/acpi_call: [QA] Fix HomepageInSrcUri
[gentoo.git] / sys-power / acpi_call / acpi_call-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit linux-info linux-mod
7
8 HOMEPAGE="https://github.com/teleshoes/acpi_call"
9 if [ "${PV}" = "9999" ]; then
10         inherit git-r3
11         EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
12         KEYWORDS=""
13 else
14         inherit vcs-snapshot
15         SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
16         KEYWORDS="~amd64"
17 fi
18
19 DESCRIPTION="A kernel module that enables you to call ACPI methods"
20
21 LICENSE="GPL-2"
22 SLOT="0"
23 IUSE=""
24
25 CONFIG_CHECK="ACPI"
26 MODULE_NAMES="acpi_call(misc:${S})"
27 BUILD_TARGETS="default"
28
29 src_compile(){
30         BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
31         linux-mod_src_compile
32 }