Merge remote-tracking branch 'github/pr/703'. Fixes bug 560362.
[gentoo.git] / sys-libs / uid_wrapper / uid_wrapper-1.1.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-multilib
8
9 DESCRIPTION="A wrapper to fake privilege separation"
10 HOMEPAGE="https://cwrap.org/uid_wrapper.html"
11 SRC_URI="ftp://ftp.samba.org/pub/cwrap/${P}.tar.gz"
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 DEPEND=""
18 RDEPEND="${DEPEND}"
19
20 # Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
21 # Because of this we cannot use cmake-multilib_src_configure() here.
22 multilib_src_configure() {
23         local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
24         cmake-utils_src_configure
25 }