dev-perl/ExtUtils-Helpers: arm stable, bug #570270
[gentoo.git] / sys-libs / ntdb / ntdb-1.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8 PYTHON_REQ_USE="threads(+)"
9
10 inherit waf-utils multilib-minimal python-single-r1
11
12 DESCRIPTION="A not-so trivial keyword/data database system"
13 HOMEPAGE="http://tdb.samba.org/"
14 SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
19 IUSE="python"
20
21 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
22
23 RDEPEND="python? ( ${PYTHON_DEPS} )"
24 DEPEND="!<net-fs/samba-4.1.7
25         ${RDEPEND}
26         ${PYTHON_DEPS}
27         app-text/docbook-xml-dtd:4.2"
28
29 WAF_BINARY="${S}/buildtools/bin/waf"
30
31 src_prepare() {
32         multilib_copy_sources
33 }
34
35 multilib_src_configure() {
36         local extra_opts=()
37         if ! multilib_is_native_abi || ! use python; then
38                 extra_opts+=( --disable-python )
39         fi
40
41         waf-utils_src_configure \
42                 "${extra_opts[@]}"
43 }
44
45 multilib_src_test() {
46         # the default src_test runs 'make test' and 'make check', letting
47         # the tests fail occasionally (reason: unknown)
48         emake check
49 }
50
51 multilib_src_install() {
52         waf-utils_src_install
53 }