sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sys-libs / musl-nscd / musl-nscd-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit systemd
7
8 DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
9 HOMEPAGE="https://github.com/pikhq/musl-nscd"
10
11 if [[ ${PV} == "9999" ]] ; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
14         EGIT_BRANCH=master
15 else
16         SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
17         KEYWORDS="~amd64 ~x86"
18 fi
19
20 LICENSE="MIT"
21 SLOT="0"
22 IUSE="minimal"
23
24 DEPEND="
25         !sys-libs/glibc
26         !sys-libs/uclibc"
27
28 src_prepare() {
29         eapply_user
30
31         sed -i '/LDFLAGS_AUTO=-s/d' configure || die 'Cannot patch configure file'
32 }
33
34 src_install() {
35         if use minimal; then
36                 emake DESTDIR="${D}" install-headers
37         else
38                 emake DESTDIR="${D}" install
39
40                 newinitd "${FILESDIR}"/nscd.initd nscd
41                 systemd_dounit "${FILESDIR}"/nscd.service
42                 systemd_newtmpfilesd "${FILESDIR}"/nscd.tmpfilesd nscd.conf
43
44                 dodoc README
45         fi
46 }