dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / sys-libs / libxcrypt / libxcrypt-2.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils ltprune multilib
6
7 DESCRIPTION="A replacement for libcrypt with DES, MD5 and blowfish support"
8 SRC_URI="mirror://debian/pool/main/libx/${PN}/${PN}_${PV}.orig.tar.gz"
9 HOMEPAGE="http://packages.debian.org/sid/libxcrypt1"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 src_prepare() {
17         epatch "${FILESDIR}/${PN}-2.4-glibc-2.16.patch"
18 }
19
20 src_configure() {
21         # Do not install into /usr so that tcb and pam can use us.
22         econf --libdir=/$(get_libdir) --disable-static
23 }
24
25 src_install() {
26         default
27         prune_libtool_files
28 }