Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / sys-libs / libvpd / libvpd-2.2.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils udev
7
8 DESCRIPTION="Library implementation for listing vpds"
9 HOMEPAGE="http://sourceforge.net/projects/linux-diag/"
10 SRC_URI="http://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
11
12 LICENSE="IBM"
13 SLOT="0"
14 KEYWORDS="~ppc ~ppc64"
15 IUSE="static-libs"
16
17 DEPEND="
18         >=dev-db/sqlite-3.7.8
19         sys-libs/zlib
20 "
21 RDEPEND="${DEPEND}"
22
23 src_configure() {
24         # sysconfdir is used only to establish where the udev rules file should go
25         # unfortunately it also adds the subdirs on its own so we strip it down to
26         # dirname
27         econf \
28                 $(use_enable static-libs static) \
29                 --sysconfdir="$( dirname $(get_udevdir) )"
30 }
31
32 src_install(){
33         emake DESTDIR="${D}" install
34         prune_libtool_files
35
36 }