sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sys-libs / liburing / liburing-0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib-minimal toolchain-funcs
7
8 DESCRIPTION="Efficient I/O with io_uring"
9 HOMEPAGE="https://github.com/axboe/liburing"
10 SRC_URI="https://git.kernel.dk/cgit/${PN}/snapshot/${P}.tar.bz2"
11 LICENSE="MIT"
12 SLOT="0"
13
14 KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15 IUSE="static-libs"
16
17 src_prepare() {
18         default
19         multilib_copy_sources
20 }
21
22 multilib_src_configure() {
23         local myconf=(
24                 --prefix="${EPREFIX}/usr"
25                 --libdir="${EPREFIX}/usr/$(get_libdir)"
26                 --libdevdir="${EPREFIX}/usr/$(get_libdir)"
27                 --mandir="${EPREFIX}/usr/share/man"
28                 --cc="$(tc-getCC)"
29         )
30         # No autotools configure! "econf" will fail.
31         TMPDIR="${T}" ./configure "${myconf[@]}"
32 }
33
34 multilib_src_compile() {
35         emake V=1
36 }
37
38 multilib_src_install_all() {
39         einstalldocs
40
41         if ! use static-libs ; then
42                 find "${ED}" -type f -name "*.a" -delete || die
43         fi
44 }