Use https by default
[gentoo.git] / sys-libs / libsepol / libsepol-2.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit multilib toolchain-funcs eutils multilib-minimal
8
9 DESCRIPTION="SELinux binary policy representation library"
10 HOMEPAGE="http://userspace.selinuxproject.org"
11 SRC_URI="http://userspace.selinuxproject.org/releases/20131030/${P}.tar.gz"
12 #       https://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND=""
21
22 # tests are not meant to be run outside of the
23 # full SELinux userland repo
24 RESTRICT="test"
25
26 src_prepare() {
27 #       EPATCH_MULTI_MSG="Applying libsepol patches ... " \
28 #       EPATCH_SUFFIX="patch" \
29 #       EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
30 #       EPATCH_FORCE="yes" \
31 #       epatch
32
33         epatch_user
34         multilib_copy_sources
35 }
36
37 multilib_src_compile() {
38         tc-export RANLIB;
39         LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
40                 emake AR="$(tc-getAR)" CC="$(tc-getCC)"
41 }
42
43 multilib_src_install() {
44         LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
45                 emake DESTDIR="${D}" install
46 }