sys-libs/libseccomp: mark 2.3.3 arm/ppc/s390 stable
[gentoo.git] / sys-libs / libseccomp / libseccomp-2.3.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 # TODO: Add python support.
5
6 EAPI="5"
7
8 inherit eutils multilib-minimal
9
10 DESCRIPTION="high level interface to Linux seccomp filter"
11 HOMEPAGE="https://github.com/seccomp/libseccomp"
12 SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="-* amd64 arm arm64 ~mips ppc ppc64 s390 x86"
17 IUSE="static-libs"
18
19 # We need newer kernel headers; we don't keep strict control of the exact
20 # version here, just be safe and pull in the latest stable ones. #551248
21 DEPEND=">=sys-kernel/linux-headers-4.3"
22
23 src_prepare() {
24         sed -i \
25                 -e '/_LDFLAGS/s:-static::' \
26                 tools/Makefile.in || die
27 }
28
29 multilib_src_configure() {
30         ECONF_SOURCE=${S} \
31         econf \
32                 $(use_enable static-libs static) \
33                 --disable-python
34 }
35
36 multilib_src_install_all() {
37         find "${ED}" -name libseccomp.la -delete
38         einstalldocs
39 }