17f614e21198a1a149a34078f565cebb672eb038
[gentoo.git] / sys-libs / libraw1394 / libraw1394-2.1.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib-minimal
7
8 DESCRIPTION="Library that provides direct access to the IEEE 1394 bus"
9 HOMEPAGE="https://ieee1394.wiki.kernel.org/"
10 SRC_URI="https://www.kernel.org/pub/linux/libs/ieee1394/${P}.tar.xz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sh sparc x86"
15 IUSE=""
16
17 multilib_src_configure() {
18         ECONF_SOURCE="${S}" econf --disable-static
19 }
20
21 multilib_src_install_all() {
22         einstalldocs
23         find "${D}" -name '*.la' -type f -delete || die
24 }