net-libs/nodejs: Versions 10.17.0 13.0.0
[gentoo.git] / sys-libs / libosinfo / libosinfo-1.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 VALA_USE_DEPEND="vapigen"
6
7 inherit gnome2 udev vala
8
9 DESCRIPTION="GObject library for managing information about real and virtual OSes"
10 HOMEPAGE="https://libosinfo.org/"
11 SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
12
13 LICENSE="GPL-2+ LGPL-2.1+"
14 SLOT="0"
15
16 IUSE="+introspection +vala test"
17 REQUIRED_USE="vala? ( introspection )"
18
19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
20
21 # Unsure about osinfo-db-tools rdep, but at least fedora does it too
22 RDEPEND="
23         >=dev-libs/glib-2.38.0:2
24         >=dev-libs/libxml2-2.6.0
25         >=dev-libs/libxslt-1.0.0
26         sys-apps/hwids[pci,usb]
27         sys-apps/osinfo-db-tools
28         sys-apps/osinfo-db
29         introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
30 "
31 # perl dep is for pod2man, and configure.ac checks for it too now
32 # Tests can use net-misc/curl, but they are automatically skipped if curl is not found, and
33 # if it is found, then those tests are skipped at runtime if LIBOSINFO_NETWORK_TESTS is unset.
34 # Due to potential network-sandbox we aren't enabling them (and one of them fails at 1.2.0).
35 DEPEND="${RDEPEND}
36         dev-lang/perl
37         dev-libs/gobject-introspection-common
38         dev-util/glib-utils
39         >=dev-util/gtk-doc-am-1.10
40         >=sys-devel/gettext-0.19.8
41         virtual/pkgconfig
42         test? (
43                 <=sys-apps/osinfo-db-20190304
44         )
45         vala? ( $(vala_depend) )
46 " # osinfo-db-20190319 and newer make tests fail; next libosinfo will remove the failing tests (moved to a future osinfo-db itself)
47
48 src_prepare() {
49         gnome2_src_prepare
50         use vala && vala_src_prepare
51 }
52
53 src_configure() {
54         gnome2_src_configure \
55                 --with-usb-ids-path=/usr/share/misc/usb.ids \
56                 --with-pci-ids-path=/usr/share/misc/pci.ids \
57                 --disable-static \
58                 $(use_enable test tests) \
59                 $(use_enable introspection) \
60                 $(use_enable vala) \
61                 --disable-coverage
62 }