Merge commit 'refs/pull/926/head' of git://github.com/gentoo/gentoo
[gentoo.git] / sys-libs / libosinfo / libosinfo-0.2.12.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 GCONF_DEBUG="no"
7 VALA_USE_DEPEND="vapigen"
8
9 inherit gnome2 udev vala
10
11 DESCRIPTION="GObject library for managing information about real and virtual OSes"
12 HOMEPAGE="http://libosinfo.org/"
13 SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2 LGPL-2.1"
16 SLOT="0"
17 IUSE="+introspection +vala test"
18 REQUIRED_USE="vala? ( introspection )"
19
20 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
21
22 RDEPEND="
23         >=dev-libs/glib-2:2
24         >=dev-libs/libxslt-1.0.0:=
25         dev-libs/libxml2:=
26         net-libs/libsoup-gnome:2.4
27         sys-apps/hwids
28         introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
29 "
30 DEPEND="${RDEPEND}
31         dev-libs/gobject-introspection-common
32         >=dev-util/gtk-doc-am-1.10
33         virtual/pkgconfig
34         test? ( dev-libs/check )
35         vala? ( $(vala_depend) )
36 "
37
38 src_configure() {
39         # --enable-udev is only for rules.d file install
40         gnome2_src_configure \
41                 --disable-static \
42                 $(use_enable test tests) \
43                 $(use_enable introspection) \
44                 $(use_enable vala) \
45                 --enable-udev \
46                 --disable-coverage \
47                 --with-html-dir=/usr/share/doc/${PF}/html \
48                 --with-udev-rulesdir="$(get_udevdir)"/rules.d \
49                 --with-usb-ids-path=/usr/share/misc/usb.ids \
50                 --with-pci-ids-path=/usr/share/misc/pci.ids
51 }