Use https by default
[gentoo.git] / sys-kernel / tuxonice-sources / tuxonice-sources-3.10.79.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 ETYPE="sources"
7 K_WANT_GENPATCHES="base extras experimental"
8 K_GENPATCHES_VER="85"
9
10 inherit kernel-2
11 detect_version
12 detect_arch
13
14 DESCRIPTION="TuxOnIce + Gentoo patchset sources"
15 HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/ http://tuxonice.nigelcunningham.com.au/ https://github.com/NigelCunningham/tuxonice-kernel"
16
17 TUXONICE_PV="3.10.77"
18 TUXONICE_DATE="2015-05-11"
19
20 TUXONICE_PATCH="tuxonice-for-linux-${TUXONICE_PV}-${TUXONICE_DATE}.patch.bz2"
21 TUXONICE_URI="http://tuxonice.nigelcunningham.com.au/downloads/all/${TUXONICE_PATCH}"
22 UNIPATCH_LIST="${DISTDIR}/${TUXONICE_PATCH}"
23 UNIPATCH_STRICTORDER="yes"
24 SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
25
26 KEYWORDS="~amd64 ~x86"
27 IUSE="experimental"
28
29 RDEPEND="${RDEPEND}
30         >=sys-apps/tuxonice-userui-1.0
31         || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
32
33 K_EXTRAELOG="If there are issues with this kernel, please direct any queries to the tuxonice-users mailing list:
34 http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
35 K_SECURITY_UNSUPPORTED="1"