sys-kernel/rt-sources: version bump to 4.4.4_p11
[gentoo.git] / sys-kernel / rt-sources / rt-sources-4.4.4_p11.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 ETYPE="sources"
7 KEYWORDS="~amd64"
8
9 HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
10
11 inherit versionator
12
13 CKV="$(get_version_component_range 1-3)"
14 K_SECURITY_UNSUPPORTED="yes"
15 K_DEBLOB_AVAILABLE="1"
16 RT_PATCHSET="${PV/*_p}"
17
18 inherit kernel-2
19 detect_version
20
21 K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
22 RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
23 RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
24                 mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
25
26 DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
27 SRC_URI="${KERNEL_URI} ${RT_URI}"
28
29 KV_FULL="${PVR/_p/-rt}"
30 S="${WORKDIR}/linux-${KV_FULL}"
31
32 UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
33 UNIPATCH_STRICTORDER="yes"
34
35 pkg_postinst(){
36
37         ewarn
38         ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
39         ewarn "If you need support, please contact the RT project developers directly."
40         ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
41         ewarn "the ebuilds."
42         ewarn
43 }
44
45 K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
46 ${HOMEPAGE}."