sys-kernel/rt-sources: version bump to 4.19.5_p4
[gentoo.git] / sys-kernel / rt-sources / rt-sources-3.18.121_p106.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 ETYPE="sources"
6 KEYWORDS="~amd64"
7
8 HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
9
10 inherit eapi7-ver
11
12 CKV="$(ver_cut 1-3)"
13 K_SECURITY_UNSUPPORTED="1"
14 K_DEBLOB_AVAILABLE="1"
15 RT_PATCHSET="${PV/*_p}"
16
17 inherit kernel-2
18 detect_version
19
20 K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
21 RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
22 RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
23                 mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
24
25 DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
26 SRC_URI="${KERNEL_URI} ${RT_URI}"
27
28 KV_FULL="${PVR/_p/-rt}"
29 S="${WORKDIR}/linux-${KV_FULL}"
30
31 UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
32 UNIPATCH_STRICTORDER="yes"
33
34 PATCHES=(
35         "${FILESDIR}"/rt-sources-posix-printf.patch # 627068
36 )
37
38 src_prepare() {
39         default
40
41         # 627796
42         sed \
43                 "s/default PREEMPT_NONE/default PREEMPT_RT_FULL/g" \
44                 -i "${S}/kernel/Kconfig.preempt"
45 }
46
47 pkg_postinst() {
48         kernel-2_pkg_postinst
49         ewarn
50         ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
51         ewarn "If you need support, please contact the RT project developers directly."
52         ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
53         ewarn "the ebuilds."
54         ewarn
55 }
56
57 K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
58 ${HOMEPAGE}."