sys-kernel/linux-firmware: bump snapshot
[gentoo.git] / sys-kernel / raspberrypi-sources / raspberrypi-sources-4.11.9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ETYPE=sources
7 K_DEFCONFIG="bcmrpi_defconfig"
8 K_SECURITY_UNSUPPORTED=1
9 EXTRAVERSION="-${PN}/-*"
10 inherit kernel-2
11 detect_version
12 detect_arch
13
14 inherit git-r3 versionator
15 EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
16 EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
17 EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
18
19 DESCRIPTION="Raspberry PI kernel sources"
20 HOMEPAGE="https://github.com/raspberrypi/linux"
21
22 KEYWORDS=""
23
24 src_unpack() {
25         git-r3_src_unpack
26         unpack_set_extraversion
27 }