sys-kernel/raspberrypi-sources: drop non-lts 3.19.9999
[gentoo.git] / sys-kernel / raspberrypi-sources / raspberrypi-sources-3.14.9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ETYPE=sources
8 K_DEFCONFIG="bcmrpi_defconfig"
9 K_SECURITY_UNSUPPORTED=1
10 EXTRAVERSION="-${PN}/-*"
11 inherit kernel-2
12 detect_version
13 detect_arch
14
15 inherit git-2 versionator
16 EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
17 EGIT_PROJECT="raspberrypi-linux.git"
18 EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
19
20 DESCRIPTION="Raspberry PI kernel sources"
21 HOMEPAGE="https://github.com/raspberrypi/linux"
22
23 KEYWORDS=""
24
25 src_unpack() {
26         git-2_src_unpack
27         unpack_set_extraversion
28 }