sys-kernel/gentoo-sources: Linux patch 4.14.181 and one additional patch
[gentoo.git] / sys-kernel / raspberrypi-image / raspberrypi-image-4.14.98_p20190215.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit mount-boot
7
8 DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
9 HOMEPAGE="https://github.com/raspberrypi/firmware"
10 LICENSE="GPL-2 raspberrypi-videocore-bin"
11 SLOT="0"
12 RESTRICT="binchecks strip"
13
14 RDEPEND="sys-boot/raspberrypi-firmware"
15
16 if [[ "${PV}" == 9999 ]]; then
17         inherit git-r3
18         EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
19         EGIT_CLONE_TYPE="shallow"
20 else
21         [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
22         MY_PV="1.$(ver_cut 5)"
23         SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
24         S="${WORKDIR}/firmware-${MY_PV}"
25         KEYWORDS="-* ~arm"
26 fi
27
28 src_install() {
29         insinto /lib/modules
30         doins -r modules/*
31         insinto /boot
32         doins boot/*.img
33 }