dev-libs/capstone: bump up to 4.0.2
[gentoo.git] / sys-kernel / linux-docs / linux-docs-5.4.31.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 MY_P=linux-${PV}
8 S=${WORKDIR}/${MY_P}
9
10 DESCRIPTION="Developer documentation generated from the Linux kernel"
11 HOMEPAGE="https://www.kernel.org/"
12 SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
17
18 IUSE=""
19 DEPEND="<=dev-python/sphinx-2.4.4"
20 RDEPEND=""
21
22 src_compile() {
23         local ARCH=$(tc-arch-kernel)
24         unset KBUILD_OUTPUT
25         emake htmldocs
26 }
27
28 src_install() {
29         HTML_DOCS=( Documentation/output/. )
30         einstalldocs
31 }