media-libs/jasper-2.0.12-r0: add alpha keyword
[gentoo.git] / sys-kernel / hardened-sources / hardened-sources-4.8.17-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 ETYPE="sources"
7 K_WANT_GENPATCHES="base"
8 K_GENPATCHES_VER="18"
9 K_DEBLOB_AVAILABLE="1"
10
11 inherit kernel-2
12 detect_version
13
14 HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-3"
15 HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
16 SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
17
18 UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
19 UNIPATCH_EXCLUDE="
20         1500_XATTR_USER_PREFIX.patch
21         2900_dev-root-proc-mount-fix.patch"
22
23 DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
24 HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
25 IUSE="deblob"
26
27 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
28
29 RDEPEND=">=sys-devel/gcc-4.5"
30
31 pkg_postinst() {
32         kernel-2_pkg_postinst
33
34         local GRADM_COMPAT="sys-apps/gradm-3.1*"
35
36         ewarn
37         ewarn "Users of grsecurity's RBAC system must ensure they are using"
38         ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
39         ewarn "It is strongly recommended that the following command is issued"
40         ewarn "prior to booting a ${PF} kernel for the first time:"
41         ewarn
42         ewarn "emerge -na =${GRADM_COMPAT}"
43         ewarn
44 }