Use https by default
[gentoo.git] / sys-kernel / hardened-sources / hardened-sources-3.2.69-r13.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 ETYPE="sources"
8 K_WANT_GENPATCHES="base extras"
9 K_GENPATCHES_VER="16"
10 K_DEBLOB_AVAILABLE="1"
11
12 inherit kernel-2
13 detect_version
14
15 HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-14"
16 HGPV_URI="https://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
17 SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
18
19 UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
20 UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
21
22 DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
23 HOMEPAGE="https://www.gentoo.org/proj/en/hardened/"
24 IUSE="deblob"
25
26 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
27
28 RDEPEND=">=sys-devel/gcc-4.5"
29
30 pkg_postinst() {
31         kernel-2_pkg_postinst
32
33         local GRADM_COMPAT="sys-apps/gradm-3.1*"
34
35         ewarn
36         ewarn "Users of grsecurity's RBAC system must ensure they are using"
37         ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
38         ewarn "It is strongly recommended that the following command is issued"
39         ewarn "prior to booting a ${PF} kernel for the first time:"
40         ewarn
41         ewarn "emerge -na =${GRADM_COMPAT}"
42         ewarn
43 }