Use https by default
[gentoo.git] / sys-kernel / hardened-sources / hardened-sources-3.14.50.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 ETYPE="sources"
8 K_WANT_GENPATCHES="base"
9 K_GENPATCHES_VER="55"
10 K_DEBLOB_AVAILABLE="1"
11
12 inherit kernel-2
13 detect_version
14
15 HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
16 HGPV_URI="https://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
17 SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
18
19 UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
20 UNIPATCH_EXCLUDE="
21         1500_XATTR_USER_PREFIX.patch
22         2900_dev-root-proc-mount-fix.patch"
23
24 DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
25 HOMEPAGE="https://www.gentoo.org/proj/en/hardened/"
26 IUSE="deblob"
27
28 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
29
30 RDEPEND=">=sys-devel/gcc-4.5"
31
32 pkg_postinst() {
33         kernel-2_pkg_postinst
34
35         local GRADM_COMPAT="sys-apps/gradm-3.1*"
36
37         ewarn
38         ewarn "Users of grsecurity's RBAC system must ensure they are using"
39         ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
40         ewarn "It is strongly recommended that the following command is issued"
41         ewarn "prior to booting a ${PF} kernel for the first time:"
42         ewarn
43         ewarn "emerge -na =${GRADM_COMPAT}"
44         ewarn
45 }