Use https by default
[gentoo.git] / sys-kernel / gentoo-sources / gentoo-sources-3.14.48.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 ETYPE="sources"
7 K_WANT_GENPATCHES="base extras experimental"
8 K_GENPATCHES_VER="54"
9 K_DEBLOB_AVAILABLE="1"
10 inherit kernel-2
11 detect_version
12 detect_arch
13
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
15 HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
16 IUSE="deblob experimental"
17
18 DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
19 SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
20
21 pkg_postinst() {
22         kernel-2_pkg_postinst
23         einfo "For more info on this patchset, and how to report problems, see:"
24         einfo "${HOMEPAGE}"
25 }
26
27 pkg_postrm() {
28         kernel-2_pkg_postrm
29 }