Use https by default
[gentoo.git] / sys-fs / xfsdump / xfsdump-3.1.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit multilib eutils
8
9 DESCRIPTION="xfs dump/restore utilities"
10 HOMEPAGE="http://oss.sgi.com/projects/xfs"
11 SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
12         ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
17 IUSE=""
18
19 RDEPEND="sys-fs/e2fsprogs
20         >=sys-fs/xfsprogs-3.2.0
21         sys-apps/dmapi
22         >=sys-apps/attr-2.4.19"
23 DEPEND="${RDEPEND}
24         sys-devel/gettext"
25
26 src_prepare() {
27         sed -i \
28                 -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
29                 include/builddefs.in \
30                 || die
31         epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
32         epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
33 }
34
35 src_configure() {
36         unset PLATFORM #184564
37         export OPTIMIZER=${CFLAGS}
38         export DEBUG=-DNDEBUG
39
40         econf \
41                 --libdir=/$(get_libdir) \
42                 --libexecdir=/usr/$(get_libdir) \
43                 --sbindir=/sbin
44 }