sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / sys-fs / unionfs-fuse / unionfs-fuse-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit python-any-r1 git-r3
8
9 DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
10 HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
11 EGIT_REPO_URI="https://github.com/rpodgorny/unionfs-fuse.git"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="sys-fs/fuse:0"
20 DEPEND="${RDEPEND}
21         test? (
22                 $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
23         )
24 "
25
26 pkg_setup() {
27         use test && python-any-r1_pkg_setup
28 }
29
30 python_check_deps() {
31         use test || return 0
32         has_version "dev-python/pytest[${PYTHON_USEDEP}]"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
37 }
38
39 src_test() {
40         addwrite /dev/fuse
41         pytest -vv || die "Tests fail with ${EPYTHON}"
42 }