dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / sys-fs / tmsu / tmsu-0.7.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit golang-build
7
8 EGO_PN="github.com/oniony/TMSU/"
9 DESCRIPTION="Files tagger and virtual tag-based filesystem"
10 HOMEPAGE="https://github.com/oniony/TMSU/wiki"
11 SRC_URI="https://github.com/oniony/TMSU/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="AGPL-3 AGPL-3+ BSD-4 GPL-3+ MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="sys-fs/fuse:0"
20 DEPEND="
21         dev-go/go-sqlite3
22         dev-lang/go
23         dev-libs/go-fuse
24         test? ( ${RDEPEND} )
25 "
26
27 src_unpack() {
28         default
29         mv TMSU-${PV} ${P} || die "Failed to move sorce directory."
30 }
31
32 src_install() {
33         dobin misc/bin/*
34         doman misc/man/tmsu.*
35         newbin TMSU tmsu
36
37         insinto /usr/share/zsh/site-functions
38         doins misc/zsh/_tmsu
39 }
40
41 src_test() {
42         cd tests || die
43         ./runall || die
44 }