dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-fs / squashfuse / squashfuse-0.1.103.ebuild
1 # Copyright 2016-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit flag-o-matic
6
7 DESCRIPTION="FUSE filesystem to mount squashfs archives"
8 HOMEPAGE="https://github.com/vasi/squashfuse"
9 SRC_URI="https://github.com/vasi/squashfuse/releases/download/${PV}/${P}.tar.gz"
10
11 LICENSE="BSD-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
14 IUSE="lz4 lzma lzo static-libs +zlib zstd"
15 REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
16
17 COMMON_DEPEND="
18         >=sys-fs/fuse-2.8.6:0=
19         lzma? ( >=app-arch/xz-utils-5.0.4:= )
20         zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
21         lzo? ( >=dev-libs/lzo-2.06:= )
22         lz4? ( >=app-arch/lz4-0_p106:= )
23         zstd? ( app-arch/zstd:= )
24 "
25 DEPEND="${COMMON_DEPEND}
26         virtual/pkgconfig"
27 RDEPEND="${COMMON_DEPEND}"
28
29 src_configure() {
30         filter-flags -flto* -fwhole-program -fno-common
31
32         local econfargs=(
33                 $(use_enable static-libs static)
34                 $(use lz4 || echo --without-lz4)
35                 $(use lzma || echo  --without-xz)
36                 $(use lzo || echo --without-lzo)
37                 $(use zlib || echo --without-zlib)
38                 $(use zstd || echo --without-zstd)
39         )
40
41         econf "${econfargs[@]}"
42 }
43
44 src_install() {
45         default
46         find "${ED}" -name "*.la" -delete || die
47 }