dev-qt/qtquickcontrols: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-fs / nilfs-utils / nilfs-utils-2.1.6.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit multilib linux-info
7
8 DESCRIPTION="A New Implementation of a Log-structured File System for Linux"
9 HOMEPAGE="http://nilfs.sourceforge.net/"
10 SRC_URI="http://nilfs.sourceforge.net/download/${P}.tar.bz2"
11
12 LICENSE="GPL-2 LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
15 IUSE="static-libs"
16
17 RDEPEND="sys-libs/e2fsprogs-libs
18         sys-apps/util-linux"
19 DEPEND="${RDEPEND}
20         sys-kernel/linux-headers"
21
22 CONFIG_CHECK="~POSIX_MQUEUE"
23
24 DOCS=( AUTHORS ChangeLog NEWS README )
25
26 src_configure() {
27         econf \
28                 $(use_enable static-libs static) \
29                 --libdir=/$(get_libdir) \
30                 --enable-libmount
31 }
32
33 src_install() {
34         default
35         rm -f "${ED}"/$(get_libdir)/*.la || die
36 }