dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / sys-fs / mac-fdisk / mac-fdisk-0.1_p18.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="Mac/PowerMac disk partitioning utility"
8 HOMEPAGE="ftp://ftp.mklinux.apple.com/pub/Other_Tools/"
9 SRC_URI="
10         mirror://debian/pool/main/m/mac-fdisk/${PN}_${PV/_p*}.orig.tar.gz
11         mirror://debian/pool/main/m/mac-fdisk/${PN}_${PV/_p*}-${PV/*_p}.diff.gz
12 "
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc ppc64 x86"
17
18 S=${WORKDIR}/${P/_p*}.orig
19 PATCHES=(
20         "${WORKDIR}"/${PN}_${PV/_p*}-${PV/*_p}.diff
21         "${FILESDIR}"/largerthan2gb.patch
22         "${FILESDIR}"/${PN}-0.1-headers.patch
23         # Patch for bug #142737
24         "${FILESDIR}"/${PN}-0.1_p16-ppc64.patch
25         ### Patch for building on amd64
26         "${FILESDIR}"/${PN}-amd64.patch
27         # Patch for large (>550GB disks)
28         # Note that >=2TB disks may not work due to limitations of the Mac
29         # Partition Table structure, this needs to be investigated
30         "${FILESDIR}"/big_pt.patch
31         "${FILESDIR}"/${PN}-0.1_p16-ppc-inline.patch
32         "${FILESDIR}"/${PN}-0.1_p18-lseek64.patch
33 )
34
35 src_compile() {
36         emake CC="$(tc-getCC)"
37 }
38
39 src_install() {
40         into /
41         newsbin pdisk mac-fdisk
42         newsbin fdisk pmac-fdisk
43
44         into /usr
45         newman mac-fdisk.8.in mac-fdisk.8
46         newman pmac-fdisk.8.in pmac-fdisk.8
47
48         dodoc debian/changelog README HISTORY
49 }