Convert URIs for googlecode.com to https
[gentoo.git] / sys-fs / lvm2 / lvm2-2.02.109.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
7
8 DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
9 HOMEPAGE="https://sources.redhat.com/lvm2/"
10 SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
11         ftp://sources.redhat.com/pub/lvm2/old/${PN/lvm/LVM}.${PV}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
16 IUSE="readline static static-libs systemd clvm cman lvm1 lvm2create_initrd selinux +udev +thin device-mapper-only"
17 REQUIRED_USE="device-mapper-only? ( !clvm !cman !lvm1 !lvm2create_initrd !thin )"
18
19 DEPEND_COMMON="clvm? ( cman? ( =sys-cluster/cman-3* ) =sys-cluster/libdlm-3* )
20         readline? ( sys-libs/readline:0= )
21         udev? ( >=virtual/libudev-208:=[static-libs?] )"
22 # /run is now required for locking during early boot. /var cannot be assumed to
23 # be available -- thus, pull in recent enough baselayout for /run.
24 # This version of LVM is incompatible with cryptsetup <1.1.2.
25 RDEPEND="${DEPEND_COMMON}
26         >=sys-apps/baselayout-2.2
27         !<sys-apps/openrc-0.11
28         !<sys-fs/cryptsetup-1.1.2
29         !!sys-fs/clvm
30         !!sys-fs/lvm-user
31         >=sys-apps/util-linux-2.16
32         lvm2create_initrd? ( sys-apps/makedev )
33         thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
34 # note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
35 DEPEND="${DEPEND_COMMON}
36         virtual/pkgconfig
37         >=sys-devel/binutils-2.20.1-r1
38         static? (
39                 selinux? ( sys-libs/libselinux[static-libs] )
40                 udev? ( >=virtual/libudev-208:=[static-libs] )
41                 <sys-apps/util-linux-2.25[static-libs]
42         )"
43
44 S=${WORKDIR}/${PN/lvm/LVM}.${PV}
45
46 pkg_setup() {
47         local CONFIG_CHECK="~SYSVIPC"
48
49         if use udev; then
50                 local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
51                 if linux_config_exists; then
52                         local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
53                         if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
54                                 ewarn "It's recommended to set an empty value to the following kernel config option:"
55                                 ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
56                         fi
57                 fi
58         fi
59
60         check_extra_config
61
62         # 1. Genkernel no longer copies /sbin/lvm blindly.
63         if use static; then
64                 elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
65                 elog "their static versions. If you need the static binaries,"
66                 elog "you must append .static to the filename!"
67         fi
68 }
69
70 src_prepare() {
71         # Gentoo specific modification(s):
72         epatch "${FILESDIR}"/${PN}-2.02.108-example.conf.in.patch
73
74         sed -i \
75                 -e "1iAR = $(tc-getAR)" \
76                 -e "s:CC ?= @CC@:CC = $(tc-getCC):" \
77                 make.tmpl.in || die #444082
78
79         sed -i -e '/FLAG/s:-O2::' configure{.in,} || die #480212
80
81         if use systemd && ! use device-mapper-only; then
82                 sed -i -e '/use_lvmetad =/s:0:1:' conf/example.conf.in || die #514196
83         fi
84
85         sed -i -e "s:/usr/bin/true:$(type -P true):" scripts/blk_availability_systemd_red_hat.service.in || die #517514
86
87         # For upstream -- review and forward:
88         epatch "${FILESDIR}"/${PN}-2.02.63-always-make-static-libdm.patch
89         epatch "${FILESDIR}"/${PN}-2.02.56-lvm2create_initrd.patch
90         epatch "${FILESDIR}"/${PN}-2.02.67-createinitrd.patch #301331
91         epatch "${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
92         epatch "${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
93         epatch "${FILESDIR}"/${PN}-2.02.92-dynamic-static-ldflags.patch #332905
94         epatch "${FILESDIR}"/${PN}-2.02.108-static-pkgconfig-libs.patch #370217, #439414 + blkid
95         epatch "${FILESDIR}"/${PN}-2.02.106-pthread-pkgconfig.patch #492450
96
97         # Without thin-privision-tools, there is nothing to install for target install_man7:
98         use thin || { sed -i -e '/^install_lvm2/s:install_man7::' man/Makefile.in || die; }
99
100         sed -i -e 's:|share):|shared):' configure.in || die #520640
101
102         eautoreconf
103 }
104
105 src_configure() {
106         filter-flags -flto
107         local myconf
108         local buildmode
109
110         myconf="${myconf} $(use_enable !device-mapper-only dmeventd)"
111         myconf="${myconf} $(use_enable !device-mapper-only cmdlib)"
112         myconf="${myconf} $(use_enable !device-mapper-only applib)"
113         myconf="${myconf} $(use_enable !device-mapper-only fsadm)"
114         myconf="${myconf} $(use_enable !device-mapper-only lvmetad)"
115         use device-mapper-only && myconf="${myconf} --disable-udev-systemd-background-jobs"
116
117         # Most of this package does weird stuff.
118         # The build options are tristate, and --without is NOT supported
119         # options: 'none', 'internal', 'shared'
120         if use static; then
121                 buildmode="internal"
122                 # This only causes the .static versions to become available
123                 myconf="${myconf} --enable-static_link"
124         else
125                 buildmode="shared"
126         fi
127         dmbuildmode=$(use !device-mapper-only && echo internal || echo none)
128
129         # dmeventd requires mirrors to be internal, and snapshot available
130         # so we cannot disable them
131         myconf="${myconf} --with-mirrors=${dmbuildmode}"
132         myconf="${myconf} --with-snapshots=${dmbuildmode}"
133         if use thin; then
134                 myconf="${myconf} --with-thin=internal --with-cache=internal"
135                 local texec
136                 for texec in check dump repair restore; do
137                         myconf="${myconf} --with-thin-${texec}=${EPREFIX}/sbin/thin_${texec}"
138                         myconf="${myconf} --with-cache-${texec}=${EPREFIX}/sbin/cache_${texec}"
139                 done
140         else
141                 myconf="${myconf} --with-thin=none --with-cache=none"
142         fi
143
144         if use lvm1; then
145                 myconf="${myconf} --with-lvm1=${buildmode}"
146         else
147                 myconf="${myconf} --with-lvm1=none"
148         fi
149
150         # disable O_DIRECT support on hppa, breaks pv detection (#99532)
151         use hppa && myconf="${myconf} --disable-o_direct"
152
153         if use clvm; then
154                 myconf="${myconf} --with-cluster=${buildmode}"
155                 # 4-state! Make sure we get it right, per bug 210879
156                 # Valid options are: none, cman, gulm, all
157                 #
158                 # 2009/02:
159                 # gulm is removed now, now dual-state:
160                 # cman, none
161                 # all still exists, but is not needed
162                 #
163                 # 2009/07:
164                 # TODO: add corosync and re-enable ALL
165                 local clvmd=""
166                 use cman && clvmd="cman"
167                 #clvmd="${clvmd/cmangulm/all}"
168                 [ -z "${clvmd}" ] && clvmd="none"
169                 myconf="${myconf} --with-clvmd=${clvmd}"
170                 myconf="${myconf} --with-pool=${buildmode}"
171         else
172                 myconf="${myconf} --with-clvmd=none --with-cluster=none"
173         fi
174
175         econf \
176                 $(use_enable readline) \
177                 $(use_enable selinux) \
178                 --enable-pkgconfig \
179                 --with-confdir="${EPREFIX}"/etc \
180                 --exec-prefix="${EPREFIX}" \
181                 --sbindir="${EPREFIX}/sbin" \
182                 --with-staticdir="${EPREFIX}"/sbin \
183                 --libdir="${EPREFIX}/$(get_libdir)" \
184                 --with-usrlibdir="${EPREFIX}/usr/$(get_libdir)" \
185                 --with-default-dm-run-dir=/run \
186                 --with-default-run-dir=/run/lvm \
187                 --with-default-locking-dir=/run/lock/lvm \
188                 --with-default-pid-dir=/run \
189                 $(use_enable udev udev_rules) \
190                 $(use_enable udev udev_sync) \
191                 $(use_with udev udevdir "$(get_udevdir)"/rules.d) \
192                 $(use_enable systemd udev-systemd-background-jobs) \
193                 "$(systemd_with_unitdir)" \
194                 ${myconf} \
195                 CLDFLAGS="${LDFLAGS}"
196 }
197
198 src_compile() {
199         pushd include >/dev/null
200         emake
201         popd >/dev/null
202
203         if use device-mapper-only ; then
204                 emake device-mapper
205         else
206                 emake
207                 emake CC="$(tc-getCC)" -C scripts lvm2_activation_generator_systemd_red_hat
208         fi
209 }
210
211 src_install() {
212         local inst
213         INSTALL_TARGETS="install install_systemd_units install_systemd_generators install_tmpfiles_configuration"
214         use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
215         for inst in ${INSTALL_TARGETS}; do
216                 emake DESTDIR="${D}" ${inst}
217         done
218
219         newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
220         newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper
221
222         if use !device-mapper-only ; then
223                 newinitd "${FILESDIR}"/dmeventd.initd-2.02.67-r1 dmeventd
224                 newinitd "${FILESDIR}"/lvm.rc-2.02.105-r2 lvm
225                 newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm
226
227                 newinitd "${FILESDIR}"/lvm-monitoring.initd-2.02.105-r2 lvm-monitoring
228                 newinitd "${FILESDIR}"/lvmetad.initd-2.02.105-r2 lvmetad
229         fi
230
231         if use clvm; then
232                 newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd
233                 newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd
234         fi
235
236         if use static-libs; then
237                 dolib.a libdm/ioctl/libdevmapper.a
238                 dolib.a libdaemon/client/libdaemonclient.a #462908
239                 #gen_usr_ldscript libdevmapper.so
240                 dolib.a daemons/dmeventd/libdevmapper-event.a
241                 #gen_usr_ldscript libdevmapper-event.so
242         else
243                 rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
244         fi
245
246         if use lvm2create_initrd; then
247                 dosbin scripts/lvm2create_initrd/lvm2create_initrd
248                 doman scripts/lvm2create_initrd/lvm2create_initrd.8
249                 newdoc scripts/lvm2create_initrd/README README.lvm2create_initrd
250         fi
251
252         insinto /etc
253         doins "${FILESDIR}"/dmtab
254
255         dodoc README VERSION* WHATS_NEW WHATS_NEW_DM doc/*.{c,txt} conf/*.conf
256 }
257
258 pkg_postinst() {
259         ewarn "Make sure the \"lvm\" init script is in the runlevels:"
260         ewarn "# rc-update add lvm boot"
261         ewarn
262         ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
263         ewarn "to enable lvm autoactivation and metadata caching."
264 }
265
266 src_test() {
267         einfo "Tests are disabled because of device-node mucking, if you want to"
268         einfo "run tests, compile the package and see ${S}/tests"
269 }