Convert URIs for googlecode.com to https
[gentoo.git] / sys-fs / lessfs / lessfs-1.5.13.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 inherit readme.gentoo
7
8 MY_PV="${PV/_/-}"
9 MY_P="${PN}-${MY_PV}"
10 DESCRIPTION="A high performance inline data deduplicating filesystem"
11 HOMEPAGE="http://www.lessfs.com"
12 SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="berkdb crypt debug filelog memtrace lzo"
18
19 DEPEND="berkdb? ( sys-libs/db )
20                 >=dev-db/tokyocabinet-1.4.42
21                 app-crypt/mhash
22                 >=sys-fs/fuse-2.8.0
23                 crypt? ( dev-libs/openssl )
24                 lzo? ( dev-libs/lzo )"
25
26 RDEPEND=""
27
28 S="${WORKDIR}/${MY_P}"
29
30 DOC_CONTENTS="Default configuration file: /etc/${PN}.cfg.
31         If your host is a client consult the following configuration
32         file: /usr/share/doc/${PF}/${PN}.cfg-slave.*"
33
34 src_configure() {
35         econf \
36                 $(use_enable debug) $(use_enable debug lckdebug) \
37                 $(use_enable filelog) $(use_with crypt crypto) \
38                 $(use_with lzo) $(use_enable memtrace) \
39                 $(use_with berkdb berkeleydb)
40 }
41
42 src_install () {
43         emake DESTDIR="${D}" install
44         dodoc ChangeLog FAQ README.*
45         insinto /etc
46         newins examples/lessfs.cfg-master ${PN}.cfg
47         dodoc examples/lessfs.* etc/lessfs.*
48         readme.gentoo_create_doc
49 }