dev-util/clair: take maintainership
[gentoo.git] / sys-fs / jfsutils / jfsutils-1.1.15.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit flag-o-matic eutils
7
8 DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
9 HOMEPAGE="http://jfs.sourceforge.net/"
10 SRC_URI="http://jfs.sourceforge.net/project/pub/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 ~sparc x86"
15 IUSE="static"
16
17 DOCS=( AUTHORS ChangeLog NEWS README )
18
19 src_prepare() {
20         epatch "${FILESDIR}"/${P}-linux-headers.patch #448844
21         epatch "${FILESDIR}"/${P}-sysmacros.patch #580056
22 }
23
24 src_configure() {
25         # It doesn't compile on alpha without this LDFLAGS
26         use alpha && append-ldflags "-Wl,--no-relax"
27
28         use static && append-ldflags -static
29         econf --sbindir=/sbin
30 }
31
32 src_install() {
33         default
34
35         rm -f "${ED}"/sbin/{mkfs,fsck}.jfs || die
36         dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
37         dosym /sbin/jfs_fsck /sbin/fsck.jfs
38 }