dev-python/elementpath: arm64 stable (bug #723996)
[gentoo.git] / sys-fs / hfsplusutils / hfsplusutils-1.0.4-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 MY_P="hfsplus_${PV}"
9
10 DESCRIPTION="HFS+ Filesystem Access Utilities (a PPC filesystem)"
11 HOMEPAGE="http://penguinppc.org/historical/hfsplus/"
12 SRC_URI="http://penguinppc.org/historical/hfsplus/${MY_P}.src.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ppc ppc64 x86"
17
18 S="${WORKDIR}/hfsplus-${PV}"
19
20 PATCHES=(
21         "${FILESDIR}"/${P}-glob.patch
22         "${FILESDIR}"/${P}-errno.patch
23         "${FILESDIR}"/${P}-gcc4.patch
24         "${FILESDIR}"/${P}-string.patch
25         "${FILESDIR}"/${P}-stdlib.patch
26         "${FILESDIR}"/${P}-cflags.patch
27         "${FILESDIR}"/${P}-fno-common-gcc10.patch
28         "${FILESDIR}"/${P}-gcc5.patch
29 )
30
31 src_prepare() {
32         default
33
34         # let's avoid the Makefile.cvs since isn't working for us
35         mv configure.{in,ac} || die
36         eautoreconf
37 }
38
39 src_configure() {
40         econf --disable-static
41 }
42
43 src_install() {
44         default
45         newman doc/man/hfsp.man hfsp.1
46
47         find "${D}" -name '*.la' -delete || die
48 }