Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / sys-fs / fuse-zip / fuse-zip-0.4.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
10 HOMEPAGE="https://code.google.com/p/fuse-zip/"
11 SRC_URI="https://fuse-zip.googlecode.com/files/${P}.tar.gz"
12
13 LICENSE="LGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=">=dev-libs/libzip-0.11.2:=
19         >=sys-fs/fuse-2.7:="
20 RDEPEND="${DEPEND}"
21
22 RESTRICT="test"
23
24 src_prepare() {
25         # Fix strip than installing fuse-zip
26         sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
27         #enable parallel build
28         sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
29 }
30
31 src_compile() {
32         emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
33 }
34
35 src_install() {
36         emake INSTALLPREFIX="${D}"/usr install
37 }